telegram plötzlich ohne funktion

  • Hallo zusammen, wir haben plötzlich das problem, das telegram ohne funktion ist. hab schon vieles versucht wie telegram zu deaktivieren - neustart - aktivieren - neustart jeden benutzer zu deaktivieren / aktivieren .... die gruppe zu deaktivieren / aktivieren .... aufem handy kann ich im telegram selbst nichts mehr steuern bzw. alle anderen ebenfalls. in der logfile steht folgendes : [08.02.2020 10:37:23 | ERROR | 14] Services.TelegramMessenger.TelegramMessengerClient TelegramBot GetUpdatesError => System.Exception: Eine Ausnahme vom Typ "System.Exception" wurde ausgelöst. bei NetTelebot.TelegramBotClient.GetUpdatesInternal(Nullable`1 offset, Nullable`1 limit) bei NetTelebot.TelegramBotClient.GetUpdates() bei NetTelebot.TelegramBotClient.updateTimer_Callback(Object state) hoffe ihr könnt mikr da ne runde weiter helfen was man noch machen könnte ^^ danke schonmal

  • Hab ich gerade in einem anderen Thema gefunden:

    EinsatzAPP Tester - Test läuft auf ein Iphone 11 mit IOS 14.0

    ---

    Orgaadmin und Helfer:

    - Ofw Friedrichsbrunn

    - Ofw Stecklenberg

    - Ofw Harzgerode

    - Ofw Neudorf/Harz

    - Ofw Meisdorf


    Mitglied in der Feuerwehr Welterbestadt Quedlinburg

    Ofw Gernrode

  • Hallo,


    Hab folgendes Problem Der Bot alarmiert nicht mehr, ich kann aber im Bot alles anzeigen lassen und auch Status setzen aber Alarme kommen keine an.

    Hat jemand das selbe problem?


    folgender Fehler kommt:

    [10.02.2020 11:58:14|ERROR| 7] EinsatzMonitorCloudAPI.SignalR.SignalRClient SignalR connection error => System.Net.WebSockets.WebSocketException (0x80004005): Ein interner WebSocket-Fehler ist aufgetreten. Weitere Informationen können Sie, sofern vorhanden, der InnerException entnehmen. ---> System.IO.IOException: Von der Übertragungsverbindung können keine Daten gelesen werden: Eine vorhandene Verbindung wurde vom Remotehost geschlossen. ---> System.Net.Sockets.SocketException: Eine vorhandene Verbindung wurde vom Remotehost geschlossen

    bei System.Net.Sockets.Socket.BeginReceive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags, AsyncCallback callback, Object state)

    bei System.Net.Sockets.NetworkStream.BeginRead(Byte[] buffer, Int32 offset, Int32 size, AsyncCallback callback, Object state)

    --- Ende der internen Ausnahmestapelüberwachung ---

    bei System.Net.Security._SslStream.EndRead(IAsyncResult asyncResult)

    bei System.Net.TlsStream.EndRead(IAsync

  • Gerade nach Alarmierung dieser Fehlercode:

    [10.02.2020 13:26:11|ERROR| 1] EinsatzMonitorCloudAPI.ConnectServiceClient Beim Aufruf des Connect-Services "Heartbeat" wurde der Fehler-Code Forbidden zurückgegeben.

    [10.02.2020 13:09:42|ERROR| 44] FeuerSoftware.EinsatzMonitor.EinsatzMonitorBackend.Printv2.OperationPrinter OperationPrinter.Start - Found 24 Vehicle

    [10.02.2020 13:09:31|ERROR| 1] EinsatzMonitorCloudAPI.ConnectServiceClient Beim Aufruf des Connect-Services "UploadNewOperationToConnect" wurde der Fehler-Code Forbidden zurückgegeben.

    [10.02.2020 13:09:30|ERROR| 1] EinsatzMonitorCloudAPI.ConnectServiceClient Beim Aufruf des Connect-Services "OperationReceived" wurde der Fehler-Code Forbidden zurückgegeben.

    [10.02.2020 12:56:11|ERROR| 1] EinsatzMonitorCloudAPI.ConnectServiceClient Beim Aufruf des Connect-Services "Heartbeat" wurde der Fehler-Code Forbidden zurückgegeben.

    [10.02.2020 12:26:11|ERROR| 1] EinsatzMonitorCloudAPI.ConnectServiceClient Beim Aufruf des Connect-Services "Heartbeat" wurde der Fehler-Cod

  • Wir nutzen: EM Versionsstand 2020.1.1.2 und Win10. Ergebnis: funktioniert wie immer, dank Sabine gestern mehrmals getestet.

    Probleme gibts z.B. beim Telegram-Push von BosMon aus in Verbindung mit Win7. Hier wurde lt. BosMon-Forum angebeblich was bei Telegram geändert, das mit Win7 Probleme bereitet. Genaueres kann ich dazu aber nicht sagen.

  • Bei uns läuft der EM auf einem Windows Server 2008 R2. Zuletzt funktioniert hat er am 01.02.2020 - danach hatten wir bis zur "Sabine" keine Einsätze, daher keine Möglichkeit, zu testen.

    Aktuell funktioniert halt auch der Weg aus dem Messenger zurück nicht, also wenn ich im Bot mit dem Kommando "zurück" oder "Status anzeigen" arbeiten will, bekomme ich nichts zurück.

  • so kommen wir mal zum kern meiner frage wieder zurück, da hier nun unterschiedliche fehler mit telegram sind


    Keine alarmierung mehr über telegram bei allen mitgliedern möglich

    Bei allen reagiert der bot in telegram nicht mehr ... das heißt man kann drücken was man will er antwortet nicht mehr


    Wie kann man den fehler beheben? Bitte so einfach wie möglich erklären ;-)

  • Ist bei mir ja nichts anderes, daher auch mein "Einklinken" in diesen Tread!

  • fraggor kann es vielleicht sein das ihr auch einen Windows Server 2008 R2 benutzt?

    Wir sind jetzt gerade soweit das wir unseren komplett neu aufsetzen müssen mit Windows Server 2019.

    Es gab starke Probleme mit der verbindung zu E-lion (ELW einsatzleitungstools) übers Internet.

    Vielleicht hat Telegramm ja auch irgendein update bekommen was nicht mehr mit Server 2008 läuft.

    Feuerwehr Wiefelstede


    IPhone XR

    iOS 13.3.1

    Alpha Test App


    Einsatzmonitor auf Windows 2019 Server mit HDMI over IP zum anzeigen auf einem 40“ Fernseher im Alarmraum.


    Connect mit Synchronisation zu E-LION


    5x EinsatzTablet

    Samsung Tab A10.1

    Android 9

  • Es werden keine updates aufem rechner durchgeführt


    Somit fliegt das als problem raus


    Nochmal zur klarstellung


    Telegram reagiert in keinster weise mehr

    Sprich:


    Kein alarm auf handy weiter schicken


    Vom handy werden keine befehle angenommen / beantwortet ( status; zurück;etc )

  • Es wird sicher auch nichts mit Updates auf einem Rechner bzw. Server zu tun haben.


    Wie von mir geschrieben: auch wir haben das gleiche Problem. Aber ich verstehe auch den Einwand von FWWiefelstede: Es kann ja ein Update des Telegram - Messengers auf dem Android oder IOS erfolgt sein, welcher jetzt den Bot nicht mehr mit dem Einsatzmonitor auf einem Windows Server 2008 R2 oder ähnlichem Betriebssystem kommunizieren lässt.


    Eventuell hat noch jemand ähnliche Probleme?! Ich werde testen, den EM mal auf einem Windows 10 System zu installieren und mit unseren Einstellungen laufen zu lassen. Ich werde vom Ergebnis hier berichten.

  • sorry war vielleicht missverständlich geschrieben. Genau so wie Mentor2002 es beschrieben hat meine ich es:thumbsup:

    Ich wollte es bei uns mit E-Lion auch nicht glauben aber das ganze System umgezogen auf einen Windows 10 Laptop und alles lief wunderbar.

    Ich komm da nur drauf weil es halt auch kommunikations probleme zwischen zwei programmen übers Internet war.

    Feuerwehr Wiefelstede


    IPhone XR

    iOS 13.3.1

    Alpha Test App


    Einsatzmonitor auf Windows 2019 Server mit HDMI over IP zum anzeigen auf einem 40“ Fernseher im Alarmraum.


    Connect mit Synchronisation zu E-LION


    5x EinsatzTablet

    Samsung Tab A10.1

    Android 9

  • Die Telegramalarmierung klappt einwandfrei. Sabine hat‘s getestet.


    Die getUpdates Abfrage liefert immer ein Ergebnis sofern der Bot Token korrekt ist.
    Beim Fehler 404 habt ihr in der URL einen falschen Bot Token verwendet.

    Lediglich ##TOKENID## muss durch euren Token ersetzt werden, /bot gehört zur URL.


    Code
    https://api.telegram.org/bot##TOKENID##/getUpdates


    Der Aufruf hat keinerlei Abhängigkeit zum lokalen System.

  • Also alte Betriebssystemversionen unterstützen bestimmte Verschlüsselungsalgorithmen nicht. Wenn jemand den Servern sagt, sie sollen nur nur TLS 1.2 machen, geht halt keine Verbindung mehr von solch alten Systemen. Ich finde es auch sehr fahrlässig solche Systeme noch im Betrieb zu haben und auch keine Updates einzuspielen.

  • Sven, liegt im auge des betrachters und was alles damit gemacht wird.


    Da nur die geringste info an telegram übermittelt wird, sehe ich was das thema daten angeht alles im grünen bereich.


    Markus82 hab gestern nochmal geschaut wie es mit dem bot ist, scheinbar redet er mit mir über deinen link. Hab gestern zwar nur alles mit dem handy machen können bis der akku leer war aber naja ... werd mich im laufe des tages mal an den rechner setzen und es mal besser machen zu können und auch mal hier rein zu schreiben was der bot sagt.


    Dennoch finde ich das ganze sehr komisch,

    Man hat nichts verändert am system, an den handys hat sich auch nichts verändert, lief seit gut 2 jahren stabil und seit dem 7.2.2020 klappt gar nichts mehr ....