Falscher Pattern bei Alarm

  • Moin,

    wir haben derzeit vier verschiedene Pattern Auswertungen.

    Zwei von ihnen sind sich ziemlich ähnlich und so kommt es bei Alarmierungen dazu, dass das falsche Pattern ausgewählt wird und so die Auswertung nicht mehr passt.

    Die beiden sehen so aus (nicht wundern, ich habe manche Platzhalter genutzt, die an der Stelle zwar falsch sind, aber das ist irrelevant):


    Mit hinterlegtem Objekt:

    {{RIC}}*{{WORTODERZAHL}}*{{EINSATZNUMMER}}*{{EINSATZBEGINN}}*{{BELIEBIGERINHALT}}*{{EINSATZSTICHWORT}}*{{SACHVERHALT}}*{{ZUSATZFELD1:INFO}}*{{SEGMENT}}*{{ZUSATZFELD2:BEMERKUNG}}*{{OBJEKT}}*{{UTMCOORDINATES}}*{{STRASSE}}*{{GMA}}*{{ORT}}*{{ORTSTEIL}}*{{ZUSATZFELD3:AAO}}


    Ohne hinterlegtem Objekt:

    {{RIC}}*{{WORTODERZAHL}}*{{EINSATZNUMMER}}*{{EINSATZBEGINN}}*{{BELIEBIGERINHALT}}*{{EINSATZSTICHWORT}}*{{SACHVERHALT}}*{{ZUSATZFELD1:INFO}}*{{SEGMENT}}*{{ZUSATZFELD2:BEMERKUNG}}*{{OBJEKT}}*{{STRASSE}}*{{GMA}}*{{ORT}}*{{ORTSTEIL}}*{{ZUSATZFELD3:AAO}}


    Der unterschied bei beiden ist, dass wenn bei der Leitstelle unter einer Adresse ein Objekt hinterlegt ist, ein Sperator mehr erscheint zwischen dem {{Objekt}} und der {{Straße}}. Hier duch {{UTMCOORDINATES}} dargestellt.

    Wenn nun zum Beispiel ein BMA Alarm eingeht, ist in den meisten Fällen ein Objekt bei der Leitstelle hinterlegt. Trotzdem wird die untere Pattern Auswertung genutzt und alle Informationen nach dem {{Objekt}} verschieben sich. Dann steht bei {{GMA}} die Straße, bei {{Ortsteil}} der Ort.


    Gruß Lasse

    • Offizieller Beitrag

    Ist UTMCOORDINATES nicht ein Zahlenformat?

    EinsatzMonitor ver. 2019.4.1.2 unter Windows Server 2016 Datacenter ver. 1607

    EinsatzApp ver. 2019.4.4 unter iPhone Xs iOS ver. 12.3 beta 1

    EinsatzApp ver. 11.0.22.6 unter iPad Pro iOS ver. 12.3 beta 1

    EinsatzTablet ver. 1.6 unter iPad Pro iOS ver. 12.3 beta 1

    EinsatzApp ver. 2019.2.1 unter Genymotion ver. 3.0.0 (Samsung Galaxy S8 mit Android 8.0)


    Groupe Cynotechnique Luxembourg

    • Offizieller Beitrag

    Doch genau das ist relevant, denn wenn dort keine Zahlen stehen kann UTMCOORDINATES das nicht auslesen, wenn es ein Zahlenformat ist... was sagt der Preview denn? Klappt es dort?

  • In der Preview funktioniert es und es gab auch schon Alarme bei denen es funktioniert hat. Das Problem ist halt nur, dass die falsche Patternauswertung den Alarm auswertet. Ich denke mal dass es daran liegt, dass das System guckt, welche Auwertung passt und als erstes feststellt, dass es auch bei der Auswertung ohne hinterlegtes Objekt passt und dann damit auswertet.

    • Offizieller Beitrag

    Nein, das System nimmt den Pattern mit den meisten Treffern und das wäre der andere. Hast Du einen Ausschnitt aus dem Log (einmal wo es passt und einmal wo es nicht passt)?

    EinsatzMonitor ver. 2019.4.1.2 unter Windows Server 2016 Datacenter ver. 1607

    EinsatzApp ver. 2019.4.4 unter iPhone Xs iOS ver. 12.3 beta 1

    EinsatzApp ver. 11.0.22.6 unter iPad Pro iOS ver. 12.3 beta 1

    EinsatzTablet ver. 1.6 unter iPad Pro iOS ver. 12.3 beta 1

    EinsatzApp ver. 2019.2.1 unter Genymotion ver. 3.0.0 (Samsung Galaxy S8 mit Android 8.0)


    Groupe Cynotechnique Luxembourg