Einsatzmonitor Freiwillige Feuerwehr Küssaberg

  • Habe nun auch die Pi's eingebaut. Habe Zero W genommen. Leider habe ich das Problem, dass nach ein paar Tage die Dinger entweder eingefroren sind oder ein File Check läuft ins unendliche. Kennt ihr das Problem? Muss ich die Dinger täglich neustarten? Ich vermute fast dass die SD-Karte von Intenso das Problem ist. habe diese aber schon gegen die baugleiche getauscht aber das Problem ist noch das gleiche.

    Hat mir jemand einen Vorschlag?


    Vielen Dank und viele Grüße!

    Fisch2005

  • Hallo Bouni,


    ich habe versucht, einen Pi nach deiner Anleitung zu installieren. Lieder sagt er mit beim Befehl sudo apt-get install xtightvncclient , dass das Paket xtightvncclient nicht gefunden werden kann. Leider sind meine Programmierkenntnisse doch eher beschränkt und ich komme an dieser Stelle nicht weiter. Kannst du mir auf Anhieb einen Tipp geben, was ich verkehrt mache?


    Danke und Grüße!

  • Hallo Bouni,


    ich habe nun die Weihnachtstage dazu benutzt, unseren EM auf den ProxMox Server umzuziehen, und deine tolle Anleitung für den Raspi dafür verwendet.
    Mein einziges Problem ist dass sich die Auflösung der VM (Windows 7pro 64Bit) immer wieder automatisch auf 1600x1200 umstellt, was dann den Full HD nicht vollständig füllt. Am ProxMox nutze ich den SPICE Grafiktreiber.

    Kennst du das Problem bzw. hast du dafür eine Lösung?


    Aber ansonsten danke für deine tolle Beschreibung!

  • Hi Bouni,


    danke für die schnelle Antwort.

    Am Server an sich hängt ein uralter Monitor über VGA, welcher aber nur auf das Terminal von ProxMox zugreift, die VM sollte damit nix zu tun haben.

    Das komische ist dass sich die Auflösung, nachdem ich diese manuell auf 1920x1080 gestellt habe ohne Neustart irgendwann wieder auf 1600x1200 umstellt, auch ohne Neustart. Habe auch im Proxmox keine Einstellung am SPICE Treiber gefunden, welche eine Auflösung vorgeben könnte.

  • Hi Bouni,


    ich habe ein Problem eventuell kannst du mir weiterhelfen.

    Kurz zum Aufbau:

    Windows 10 läuft auf einem Esxi, UltraVNC Server ist installiert und läuft ebenfalls. Der Display hat eine Auflösung von 1920 x 1080. Der Raspberry hat auch als Auflösung 1920 x 1080.


    Wenn ich mich jetzt mit

    Code
    1. xtightvncviewer -viewonly -fullscreen xxx.xxx.xxx.xxx

    einwähle funktioniert das alles soweit.


    Allerdings ist mein gespiegelter Desktop größer als 1920 x 1080 und ich kann auf dem Raspberry hin und her scrollen, dass ich alle Inhalte sehe.

    Woran könnte das liegen, dass die Auflösung dann größer ist?


    Gruß

    Philipp

  • Morgen Philipp112,


    gute Frage, wie viel zu gross ist es denn?

    Ich hab bei mir mit den Parametern in der /boot/config.txt spielen müssen um den screen "einzupassen". Allerdings war dieser bei mir einfach nicht passend, scollen konnte ich da nichts.


    Mach mal auf dem Pi ein tvservice -s da müsste dann sowas wie das hier als Ausgabe rauskommen:

    state 0x12000a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive

    Und dann noch ein cat /boot/config.txt, poste dann den Output hier, das müsste so in etwa so aussehen:


    Mal sehen, vlt. kann ich das Problem so erkennen.

  • Hallo Bouni,


    ganz vielen Dank für deine tolle Anleitung. Wir haben das System jetzt bei uns in Langwedel (Landkreis Verden, NI) auch umgesetzt. Ein Windows 10 PC, der von 2 Raspis in unsere zwei Hallen gespiegelt wird (an den Raspis jeweils noch ein HDMI-Multiplyer).


    Bei der Installationen hatte ich allerdings extremen Ärger mit Windows, weil einfach keine Verbindung zustande kam. Was ich herausgefunden habe, damit es geht:

    • Die Raspis müssen eine Netzfreigabe vom Hauptrechner über samba gemountet haben (dafür einloggen mit Passwort), sonst "versteckt sich der Windows 10 Rechner. Die Kommandos kann ich euch gerne geben
    • Der Windows 10 Rechner muss jeden Raspi mindestens einmal angepingt haben. Sobald der Ping durch ist, wird die Verbindung sofort hergestellt. Das habe ich über eine *.bat-Datei gelöst, die über die Taskplanung alle 5min ausgeführt wird.

    Vielleicht hilft es ja jemanden und erspart ihm eine schlaflose Nacht ;-) . Ich stelle aber unsere Konfig auch noch einmal in einem eigenen Beitrag vor, wenn alle Kabel ordentlich verlegt sind.


    Viele Grüße

    Thorben

  • Guten Morgen Torben,


    Zitat

    Die Raspis müssen eine Netzfreigabe vom Hauptrechner über samba gemountet haben (dafür einloggen mit Passwort), sonst "versteckt sich der Windows 10 Rechner. Die Kommandos kann ich euch gerne geben

    Das scheint mir aber ein Problem mit eurer Netzwerk Konfiguration zu sein. Wenn ihr über die IP geht und nicht über de Hostnamen des Windows Rechners dann sollte die Network Discovery keine Rolle spielen. Aber wenn's so für euch funktioniert dann ist ja gut!


    Zitat

    Der Windows 10 Rechner muss jeden Raspi mindestens einmal angepingt haben. Sobald der Ping durch ist, wird die Verbindung sofort hergestellt. Das habe ich über eine *.bat-Datei gelöst, die über die Taskplanung alle 5min ausgeführt wird.Auch das ist recht seltsam, braucht es das damit der VNC verbindet oder das du die Kommandos zum ein- bzw. auschalten senden kannst?


    Ich hab schon vor einer Weile ein Ansible playbook geschrieben mit dem sich die Pi's innerhalb von 5 Minuten automagisch konfigurieren lassen, man muss lediglich anfangs das Raspbian Lite Image auf die SD Karte spielen und SSH aktivieren, alle nachfolgenden Schritte erledigt Ansible. Ich werd demnächst nochmal ein Tutorial hier im entsprechenden Breiech veröffentlichen, muss allerdings davor noch eine Änderung am CEC Teil vornehmen.


    Gruss Bouni